• Payment Plugins Poll

    We need your feedback on the need for updated payment plugins. Please go here and give us your feedback.

  • Joomla 5.1

    For running J!5.1 you must install Fabrik 4.1
    See also Announcements

  • Subscription and download (Fabrik 4.1 for J!4.2+ and J!5.1) are working now

    See Announcement
    Please post subscription questions and issues here

    We have resolved the issue with the J! updater and this will be fixed in the next release.

  • Update & Changlog URL Fixer

    At the present time the update site URL for Fabrik is incorrect in all installations up to and including 4.1. This will be corrected in 4.2, however, if you wish to update Fabrik via the J! Updater you can download and install this plugin.

    This file is installed just like any other extension through the J! Extension Installation panel. It will not however actually install anything. Its sole purpose is to fix the Update Site and Changlog URL's. Once done it will simply exit.

    As always, we recommend you perform a site backup priot to installation.

Suddenly cannot make any changes nor create anything new J4/F4

molcomp

Member
Hello,

I am having some weird issues with Fabrik 4 and Joomla 4.
It was all working fine for some time then I wanted to make some changes.
I created a new list based on a copy of an existing list . Then I edited the newly created list but I cannot make any changes to it.

I tried creating a new list without copying its not allowing me , screen refreshes then I am back at the empty form for list creatiion.

Then I tried creating new form, new element and I cannot do any of that. Debug is not showing much except some minor php notices.

Anyone has any idea how to resolve the issue? I have cleared browser and joomla cache.

Thanks
Alex
 
Last edited:
Hello @troester. Thank you for your help.
I am using J 4.4.4, Fabrik Version: 4.0 (GitDate: 2024/01/3), PHP Version 8.1.28.
I have several lists that were initially working and then I wanted to add another list when I noticed that I cannot create anything new.

Thank you
Alex
 

Attachments

  • after-form-saved-load.png
    after-form-saved-load.png
    157.6 KB · Views: 42
  • when-new-form-loaded.png
    when-new-form-loaded.png
    191.5 KB · Views: 38
I assume the reason is this [Violation] (which I never have seen).
Do you have any special browser (e.g. security) settings?
Did you try an other browser?
Is it different if you set the J! default editor to none (Global Config)?
 
That is the only thing I am seeing (that Violation). I have ad blocker in the chrome but I have tried also mozilla as well nothing special settings on both just default.
I just tried defailt editor none the same result.
 
Just disabled all extensions in the browser that were there still the same. Cannot create form/list/element. I can duplicate a list and set a different name in the process but afterwards I cannot alter anything in the new list.
 
I have just noticed the following:
Even if I just edit a list and click close afterwards the window refreshes and returns to the same window and on the second close it gives me no results found while in the url still says
XXXXXX/administrator/?option=com_fabrik&view=list&layout=edit&id=33
 
I did restart both mysql/apache and checked db tables through phpmyadmin it was all good. I also tried to make some changes from another computer but the problem remains.
 
No idea. Did you try to re-install F4 or do a GitHub update? Maybe something is corrupted.
 
I have rebooted the whole server and the general issue is resolved. Fabrik works normal now in general. Just for some reason there is still some issue I believe with some cache within and between joomla and fabrik. When creating or editing a menu item with fabrik list I have to alter the slug otherwise filtering set in the list does not work although the proper list loads. Not sure why is that but its not a big issue at the moment.
Thank you @troester
Alex
 

Members online

No members online now.
Back
Top