• Hello Fabrik Community

    Fabrik is now in the hands of the development team that brought you Fabrik for Joomla 4. We have recently transitioned the Fabrik site over to a new server and are busy trying to clean it up. We have upgraded the site to Joomla 4 and are running the latest version of Fabrik 4. We have also upgraded the Xenforo forum software to the latest version. Many of the widgets you might have been used to on the forum are no longer operational, many abandoned by the developers. We hope to bring back some of the important ones as we have time.

    Exciting times to be sure.

    The Fabrik 4.0 Official release is now available. In addition, the Fabrik codebase is now available in a public repository. See the notices about these in the announcements section

    We wish to shout out a very big Thank You to all of you who have made donations. They have really helped. But we can always use more...wink..wink..

    Also a big Thank You to those of you who have been assisting others in the forum. This takes a very big burden off of us as we work on bugs, the website and the future of Fabrik.

Fixed (SOLVED) Before i go crazy, i need to ask .. Are the Search Form Working on Fabrik4?

jmoises

Active Member
Are the Search Form Working on Fabrik4?

I create one following this tutorial https://fabrikar.com/forums/index.php?wiki/create-a-search-form/

- first try that i create the form is not in the list of forms, but if i create a menu i can see is there.
- second, i make sure to select a group the form is there in form list, but when i use the form i get this error:

1103 Incorrect table name ''​


Thanks for any help, i keep trying but if somebody have any info on this i will apreciate!

Version :
Joomla 5, Fabrik4 Updated site, from 3.12
 
Last edited:
I create a 3 and same result it didnt show in form list, creates the group, but not the form
1708133629388.png

1708133652139.png

Also if i try to create the menu, the form shows there
1708133820562.png


Here you can see is not show in fabrik form list
1708133879915.png
 
I've never made a search form myself, but probably it would be better to start with a list and then disable save to database (form processing) in the form afterwards....
 
I think there's a big bug at the moment, you can't start with creating a form (also if it's no recording to DB).

Try:
Create a (dummy) list, then set the created form to "Record to DB"=no.
After this you can delete the list (but not form/group/elements)
 
Issue should be fixed in the next release (resp. in Monday's GitHub build).

For those who are interested right now:
administrator\components\com_fabrik\models\form.php
 

Attachments

  • form.zip
    4.9 KB · Views: 29
@troester , i copy the form.zip you attach early to administrator\components\com_fabrik\models\form.php, and try creating again but same result , i follow this instructions:

Try:
Create a (dummy) list, then set the created form to "Record to DB"=no.
After this you can delete the list (but not form/group/elements)

This work ok except i was not able to delete the list only, i didnt found a way to do that.

i will mark the tread solve thanks!
 
i may did something wrong again, i did exatly what you mention before, but it remove all even when i toll only the list only.
 
It's all still there, but in trash.

So this workaround to get a form not recording to DB (create list, then trash and delete it) is a bit complicated.
But with the fix such a form can again be created directly.
 
i try it again multiple times. the only way to keep the form is if i dont delete the dummy list..

---------------------------------------------------------------------------------
Try:
Create a (dummy) list, then set the created form to "Record to DB"=no.
After this you can delete the list (but not form/group/elements)
 
We are in need of some funding.
More details.

Thank you.

Members online

Back
Top