Issues with Menu items with Row ID set as -1



If I use -1 on a Menu Item so that the owners records load by default this issue occurs.

When user fills form incorrectly and submit, the form shows the error tip and warnings BUT the elements are rendered as read-only for fields set to be editable by only owner.

This is an issue since the owner can now not make corrections to the fields and would need to refresh the page and fill the whole form all over again

Note that, I dont want public to be able to edit these elements but I need them to be able to view the elements.
I can't replicate, (failed) validation is working on my site as expected.
As I said in your other thread
If the user doesn't "own" a record (precondition: the record has an element storing the Joomla userID, this is NOT the primary key of the record) he will get the empty form for adding a record (precondition: list access setting "Add record" = registered (or public)),
if there's alread a record he gets the form with the data for editing (precondition: list access setting "edit record" = registered)

To prevent the user from seeing (and editing) records from others set a prefilter.

If the user should be able to see all records but edit only his own one set "canEditRow" list plugin.
What are your list access settings, your element access settings?
I can't replicate this either.

Are you also using the 'Key Name' ("usekey") setting? You pretty much have to, if you use rowid -1.

The way that feature works is that rowid -1 sets the rowid for the form being loaded to the logged in user ID. But that almost certainly won't be the primary key of the form. So you also need to tell Fabrik which element you want to use to identify the row to load. Which would usually be a 'user' element.

The use case for this is where you have a list where each user "owns" a single row. Like a user profile table. By setting rowid=-1 / usekey=your_user_element, you tell Fabrik to load the row for (say) logged on user ID 123 by doing "WHERE your_user_element=123", rather than "WHERE id=X" (where X is whatever the "real" rowid is). If that row exists, Fabrik loads it. If not, we create a new one - and assuming your usekey element is a 'user' element, that will automatically get saved as the logged on user ID, so next time you load the form, it'll find and load it.

-- hugh

See the following:
All screenshots in link

This file shows access level of the elements of this form
access level - from - element.PNG

This shows the access level of the list
access level - education - list.PNG

I have a separate element for userid same with what was specified on the menu item
key row.PNG

See menu item
Menu - form - education.PNG
User's record load ok when user visits the form
Frontend User - Record Loads Correctly.PNG

If user fills incorrectly, then user cannot edit form again until the url is re-entered. Refresh doesn't work.
after error - user cannot make correction.PNG
Can you provide credentials in your My Sites for this site? I've tried setting up a test here with similar ACL's, but just can't replicate what you are seeing. I need to look at the backend and go through your settings.

-- hugh

Does your user 'userid' element itself have ACL's on it? On a hunch I tried setting the add/edit ACL on my userid element (to the same as the other elements I'm testing with, so Registered and Super User / 'or user' userid), and with that setup, I get the same issue as you.

So, if your userid element has ACL's on it, try setting those to Public, see if that helps.

I'm currently trying to figure out why this happens, I can kinda see, it's a sort of Catch 22 / chicken & egg thing ... I may or may not come up with a fix for it ... but for now a workaround would be to remove the restrictive ACL on the user element.

-- hugh
Changed all userid elements to public. No luck.
I have added the admin credentials.

PS: I notice one of the elements dont have this issue. The detail element remains editable. I checked and the settings are the same with other elements so I'm wondering what is wrong
I can really only juggle a certain number of questions from one user at a time. This one is in the queue behind several of your others.

-- hugh
Hello, a handful of my requests are a week old now and unanswered. Do I need to post a reminder on all of them or just this one is ok.
Feel free to bump a thread, once it's more than 3 days.

Which site / form is this on? I still can't replicate the problem here, unless I restrict access to the user element. I obviously need to log in to your site, check your settings, and try and replicate them exactly here.

-- hugh
I don't seem to be able to get through the htaccess for the backend. I've copied and pasted the credentials you gave us twice.

-- hugh
Tested it again now and it still works ok.
Did you check the notes I attached to the site? If no, then you'll find the htaccess credentials there. If yes, please ensure you are not copying and pasting spaces. A lot of times, copying and pasting includes spaces in what was copied.
I am positive I'm copying it correctly. Just tried again.

Ah, the problem is http vs https. The link you gave us is http, but apparently the htaccess only works for https.

So I'm in on the backend. I'll find some time today to check your setup and try and replicate the issue locally.

-- hugh
Ok. Great to hear that. I dont think you would have been able to reach the http site cos I forced https sitewide and also www. (One of the reasons was because I noticed the comments only appear on the exact url they were posted on). I might need to open a forum post for help/advice if I cant get all instances of a form to load using the same url(I see there are lots of ways to reach a form).

Ok. I just tried using http.

Apparently, there are two redirects when you visit the http. One to https and the second one to https://www but not before you get the prompt for the folder password. Hence, you'll be asked for the same credential 3x if you use the http link instead of the https://www.

I'll note this for future link provisions
Last edited:
Not sure where I left off. I think my threads have missing portions because I'm rather sure I cant find some of our discussions on the threads.

I also can't find where to view all my posts per topic. I can only find them per response which is a bit clumsy finding each thread.

I still need to solve this.
I cant find the professional support subscription page.
How do I proceed?
We're in the process of changing how we provide support. We had hoped to announce the new structure this week, but Robbie is dealing with illness in the family, and hasn't had the time to work on it.

I think the only way we'll be able to get further with this is if I get an Akeeba of your site and install it here, which would need to be billable work.

-- hugh
Hello @cheesegrits I still have this issue. I really need this to be solved in order for the website to be useable.
I tried filling the form at the Help Center but it throws an error.
How do I proceed on this?
We are in need of some funding.
More details.

Thank you.

Members online