• Payment Plugins Poll

    We need your feedback on the need for updated payment plugins. Please go here and give us your feedback.

  • Joomla 5.1

    For running J!5.1 you must install Fabrik 4.1
    See also Announcements

  • Subscription and download (Fabrik 4.1 for J!4.2+ and J!5.1) are working now

    See Announcement
    Please post subscription questions and issues here

    We have resolved the issue with the J! updater and this will be fixed in the next release.

  • Update & Changlog URL Fixer

    At the present time the update site URL for Fabrik is incorrect in all installations up to and including 4.1. This will be corrected in 4.2, however, if you wish to update Fabrik via the J! Updater you can download and install this plugin.

    This file is installed just like any other extension through the J! Extension Installation panel. It will not however actually install anything. Its sole purpose is to fix the Update Site and Changlog URL's. Once done it will simply exit.

    As always, we recommend you perform a site backup priot to installation.

Solved Copied list does not group in alpha order

Today I made a copy of a list (so that I could have some joins in one list view while keeping my forms distinct). After copying the list, i noticed that no matter what i did, I could not get the copied list to display groups in any order. I tried a few different fields as the field to group on, and all of them produce unordered results. (I suspect the order is actually according to which group value is found next in the list.) Changing the order direction doesn't help. The problem occurs in both the front and back end. There is no problem with the original list. Here's a screen shot of the list in the front end:
Screenshot 2024-05-10 at 6.14.44 PM.png


And here are the group settings:
Screenshot 2024-05-10 at 6.16.23 PM.png


I am running j5.1 with the manual update installed. Joomla Debug is on and there are no messages on this page.
 
Did you try to set the sorting in the data tab (in your screenshot left from 'group by' )
Yes, the records were sorted by a name field. Changing the sort order doesn't seem to change/correct the group ordering issue. Columns that don't appear alphabetize correctly in the group by do alphabetize correctly in as a record sort order. So the problem doesn't seem related to my data. Was that the thinking behind the question?

Even after adding the group-by field to the data sort, the groups sort weirdly. Here it is with records sorted by last name (of the primary member) and by membership type and grouped by membership type:
Screenshot 2024-05-11 at 9.21.32 AM.png
 
As @wezetel said: To order your "group by" element (city in your 1st example) you must set the "Order by" in the Data tab.

Order by in "Group by" tab is for the order inside each group.


1715449112710.png
 
Back
Top